Делаем port-channel

Настройка Port-channel на коммутаторе Cisco.

Время идёт — компании растут, осваивают новые рынки и охватывают новые зоны. Соответственно разрастается и их инфраструктура. Рано или поздно,  каждый администратор сталкивается с необходимостью расширения пропускной способности канала до определённой точки или организации резервного канала. Порой возможности качественно (например заменой медного канала на оптический) нет возможности — материальной или иной — не важно. В этом случае на помощь придёт очень удобная функция организации Port-channel.

Рассмотрим настройку Port-channel на примере расширения медного 100-мегабитного канала между двумя коммутаторами Cisco Catalyst 2950 путём подключения дополнительного канала.

На первом коммутаторе Cisco Catalyst 2950 делаем следующее:
1. Создаём интерфейс Port-channel.

interface Port-channel1
description primer_port-channel
switchport mode trunk
no ip address
flowcontrol send off

В моём случае необходим trunk’овый канал, поэтому указываем это при настройке интерфейса Port Channel строкой:

switchport mode trunk

Теперь по очереди настраиваем оба интерфейса — в данном примере это 100-мегабитные FastEthernet-порты. Они настраиваются так же в режим trunk. Прописываем FastEthernet 1:

interface FastEthernet0/1
description kanal_1
switchport mode trunk
no ip address
channel-group 1 mode active

Теперь прописываем порт FastEthernet 2:

interface FastEthernet0/2
description kanal_2
switchport mode trunk
no ip address
channel-group 1 mode active

На принадлежность портов к интерфейсу Port-Channel 1 указывает строка:

channel-group 1 mode active

Теперь то же самое необходимо будет прописать на втором коммутаторе с другой стороны.

Помогло? Посоветуйте друзьям!



Делаем port-channel: 2 комментария

  1. Роман

    Молодец, парень! Все доступно и понятно даже тем, кто не имел с этим дел.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *