Cisco 877(857)

Базовая настройка маршрутизатора cisco 877 (857).

Маршрутизаторы Cisco 870 series предназначены для подключения к Интернет офисов небольших компаний или филиалов.
Маршрутизаторы серии включают мощные средства обеспечения безопасности. Выполняя функции брандмауэра на границе сети, данные маршрутизаторы выполняют инспекцию входных IP-пакетов, защищают сеть от внешних вторжений и вирусных атак.
Cisco 877 обладает 4-мя портами LAN и одним портом ADSL.
Всё это нам рассказал Cisco.com о своём детище. Действительно, это производительное и надёжное железо, которое работает на отказ не год и не два, а значительно дольше.

cisco_877_pic01

Ну что же, перейдём от теории к практике и настроим маршрутизатор. Пример настройки я приведу для vpi/vci 0/33. Обязательно уточните их у своего провайдера. Впринципе конфигурация подойдёт под любого провайдера, использующего PPPoE.

В листинге конфигурации добавлены комментарии к самым важным моментам, если что-то из команд не совсем понятно — уточнить можно по справочникам Cisco.

version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!

###Пропишем имя хоста для нашего маршрутизатора:

hostname router
!
boot-start-marker
boot-end-marker
!
### Установим пароль на режим enable:

enable password mypassword
!
no aaa new-model
!
resource policy
!
no ip source-route
!
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
### Поднимаем DHCP
ip dhcp pool local_net
import all
network 192.168.1.0 255.255.255.0
dns-server 88.147.129.15 88.147.128.17
default-router 192.168.1.1
!
!
ip tcp synwait-time 10
no ip bootp server
ip domain name domain.local
ip name-server 88.147.129.15
ip name-server 88.147.128.17
ip ssh time-out 60
ip ssh authentication-retries 2
!
### Активируем режим irb
bridge irb
!
### Заводим WAN-интерфейс
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
### Так как у нас 1 канал PVC, то и саб-интерфейс будем заводить один
interface ATM0.1 point-to-point
description $WAN$
no snmp trap link-status
!
### Прописываем парамеры канала vpi — 0 и vci — 33
pvc 0/33
pppoe-client dial-pool-number 1
!
!
bridge-group 1
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
### Поднимаем интерфейс, смотрящий во внутреннюю сеть
interface Vlan1
description $INSIDE$
ip address 192.168.1.1 255.255.255.0
ip access-group 101 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
!

###Так как необходимо поднять PPPoE-клиент,то поднимается интерфейс Dialer.
interface Dialer0
description $OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip inspect DEFAULT100 out
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
### Указываем типы авторизации
ppp authentication chap pap
### Прописываем логин и пароль на доступ в Интернет для каждого типа
ppp chap hostname my_login
ppp chap password 7 my_password
ppp pap sent-username my_login password 7 my_password
!
### Указываем дефолтовый маршрут
ip route 0.0.0.0 0.0.0.0 Dialer0
!
### Отключаем встроенный HTTP сервер
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
### Разрешаем всё для нашего аксесс-листа. Если же необходимо ограничить доступ к/от другим сетям, то необходимо будет под каждую из них прописывать правила.
access-list 101 permit ip any any
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
bridge 1 protocol ieee
!
line con 0
login local
no modem enable
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!

Помогло? Посоветуйте друзьям!



Cisco 877(857): 7 комментариев

  1. Сергей

    Здравствуй!
    Подскажите пожалуйста такой момент, железки cisco настраиваются только через консольный доступ или все таки у них есть свой web-interface ???
    Заранее спасибо )

  2. XasaH Автор записи

    Да как бы есть, но через веб-интерфейс с циской никто не работает. Через консоль значительно проще и удобнее.

  3. Федя

    Здравствуйте! Пожалуйста, напишите кто-нибудь конфиг для Cisco С837, у которого аналогично 4 порта LAN и 1 порт для ADSL, но при этом VLAN’а у этого маршрутизатора нет. Хочу настроить данный маршрутизатор для домашнего использования с интернетом ADSL от провайдера Таттелеком (Летай). По уровню знаний Cisco я не очень, но работать через консоль умею, поэтому хотелось бы получить конфиг с подробными разьяснениями пошагово, плиз…

  4. Артем

    После заливки конфиги циски пароль получается будет «mypassword» логин тогда какой? по HT пускать тоже не будет?

  5. XasaH Автор записи

    Артем — логин она спрашивать не будет, сразу запрос пароля пойдёт.

  6. Алексей

    Доброго дня ! Подскажите пожалуйста а если провайдер дал авторизацию по IP. И CISCO 877W коннектится в режиме моста 83.139.19.210 пробрасывает все порты на белый IP адрес сетевой платы 83.139.19.209. Тогда как настроить CISCO?

  7. XasaH Автор записи

    Вместо ПК поставьте нормальный WiFi роутер, пропишите IP на нём и будет Вам счастье.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *