Настройка портов Cisco

В рамках сегодняшней статьи я расскажу как настроить физический порт на коммутаторах Cisco в режиме Access и Trunk, а так же каким образом заставить его работать в так называемом гибридном режиме. Давайте подробнее разберемся что из себя представляет каждый из этих типов и каким образом он конфигурируется.
Для примера рассмотрим Cisco Catalyst 2950. Для 2960, 2970, 3550, 3560 и ME3400 — все действия те же самые.
Первым делом, надо зайти в режим глобальной конфигурации устройства и войти в параметры нужного порта:

conf t
interface fa0/2

1. Access Port.
Это оконечный порт коммутатора, который смотрит в сторону оконечного клиентского устройства доступа — модема, WiFi-роутера или просто компьютера, к которому трафик идет уже в нетегированном виде.
Конфиг выглядит вот так:

как настроить порт cisco

С помощью команды switchport mode access мы переводим порт в режим аксесс. При этом в сторону этого порта будет идти трафик по так называемой native vlan, которой как правило выступает vlan 1.

Если же мы наберем команду:

switchport access vlan 310

как настроить порт cisco

В этом случае пойдет трафик, принадлежащий vlan 310.

2. Trunk port. Такой вариант используется в том случае, когда организуется канал между двумя сетевыми устройствами — то есть с другой стороны стоит коммутатор или маршрутизатор. Поэтому транковый порт в некоторых случаях называют магистральным. Через него передается трафик по нескольким vlan.
Конфиг на 2950 выглядит так:

как настроить порт cisco

То есть, для catalyst 2950 достаточно в параметрах порта прописать строку:

switchport mode trunk

Если у Вас коммутатор 2960 и выше, то необходимо ещё ввести команду:

switchport trunk encapsulation dot1q

как настроить порт cisco

Всё дело в том, что 2950 умеют работать только с 802.1q, в то время, как более новые устройства поддерживают инкапсуляцию ISL, поэтому тип инкапсуляции на порту надо указывать явно.

Если надо разрешить проходить через транковый порт только определенным vlan’ам — указываем их с помощью команды switchport trunk alloved vlan и указываем через запятую идентификаторы.
В моем случае для vlan 310 и 555 команда будет выглядеть так:

switchport trunk alloved vlan 310, 555

как настроить порт cisco

3. Hybrid port.
Коммутаторы Cisco не позволяют явно прописать на порту type Hybrid, но сделать порт гибридным можно указав  для транкового порта свой nativ vlan.
Для примера, я сделаю trunk-порт, на котором в транке будет vlan 555, а в то же время, весь нетегированный трафик на порту будет заворачиваться во vlan 310:

switchport mode trunk
switchport trunk alloved vlan 310,555
switchport trunk native vlan 310

как настроить порт cisco

Помогло? Посоветуйте друзьям!



Настройка портов Cisco: 5 комментариев

  1. Root

    Это не гибридный порт, это обычный транк-порт. Просто по дефолту native-vlanid = 1

  2. Михаил

    Доброго дня. Расскажите пожалуйста про работу с коммутаторами huawei quidway s2326tp-ei. Первоначальная настройка, сохранение конфигурации…..

  3. XasaH Автор записи

    Здравствуйте. Как только будет на них время — обязательно сделаю!

  4. Александр

    Спасибо, отличная статья, очень простая и доступная!!! А самое главное полезная. Спасибо!!!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *